Confiuring VLAN and Etherchannel using Aruba 6000 with Cisco 3750 Switch

posted 12 Jun 2011, 04:47 by Tristan Self
We were setting up an Aruba with a Cisco 3750 we are trying to allow trunking of VLANs to the aruba from the switch and also bonding both the NICs on the aruba to two ports on the cisco in an etherchannel to give us 2GB uplink.

heres how we did it, we didn't need to set any speed settings on the cisco, but did on the aruba end.

------------------------------------------------------------------
Aruba Config:

interface gigabitethernet  2/0
description "gig2/0"
trusted
trusted vlan 1-4094
speed 1000
duplex full
switchport mode trunk
no spanning-tree
!

interface gigabitethernet  2/1
description "gig2/1"
trusted
trusted vlan 1-4094
speed 1000
duplex full
switchport mode trunk
no spanning-tree
!

interface port-channel 1
add gigabitethernet 2/0
add gigabitethernet 2/1
trusted
trusted vlan 1-4094
switchport mode trunk
switchport trunk allowed vlan 1,202
no spanning-tree
!

interface vlan 1
ip address 172.17.100.1 255.255.0.0
!

interface vlan 192
ip address 192.168.1.32 255.255.255.0
!

interface vlan 202
ip address 172.27.2.50 255.255.255.0
!

ip default-gateway 172.17.2.1

----------------------------------------------------------------
Cisco Config:

interface GigabitEthernet1/0/11
description *** Aruba 6000 Wireless Controller - NIC 1 ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,202
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0/12
description *** Aruba 6000 Wireless Controller - NIC 2 ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,202
switchport mode trunk
channel-group 1 mode on
!

interface Port-channel1
description *** Etherchannel to Aruba 6000 Wireless Controller ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,202
switchport mode trunk
Comments