HP BladeSystem Flex 10 Ethernet Switch Configuration

posted 19 Aug 2016, 07:46 by Tristan Self
Had to do a bit of configuration on an HP c7000 blade chassis the other day. There was a need to have two separate uplink pairs going to two different pairs of switches from the single chassis. I needed to provide both uplink paths to each host within the chassis (they were ESXi hosts).

Here is the configuration to do this for one of the uplink pairs, for the other uplink pair you just do the same thing, but applying the server-port-map-range to different physical ports on the blade. Each blade has 8 pNICs (4 on the LOM and 4 on a mezzanine card).

In this example ports 3 and 4 are going to be used to provide active/standby paths through the Flex-10 fabric to the physical network beyond.

add uplinkset VLAN_Trunk_1 ConnectionMode=Failover
add uplinkport enc0:1:X4 UplinkSet=VLAN_Trunk_1 Speed=Auto Role=Primary
add uplinkport enc0:2:X4 UplinkSet=VLAN_Trunk_1 Speed=Auto Role=Secondary

add network vlan1 -quiet UplinkSet=VLAN_Trunk_1 VLanID=552 NativeVLAN=Enabled NAGs=Default
set network vlan1 SmartLink=Enabled

add network vlan2 -quiet UplinkSet=VLAN_Trunk_1 VLanID=555 NAGs=Default
set network vlan2 SmartLink=Enabled

add network vlan3 -quiet UplinkSet=VLAN_Trunk_1 VLanID=554 NAGs=Default
set network vlan3 SmartLink=Enabled


If you want vlan1 to be untagged to the host where these 3 vlans are trunked to the host on ports 2 and 3, you need an extra bit of configuration:

set server-port-map serverprofile1:3 vlan1 untagged=true
set server-port-map serverprofile1:4 vlan1 untagged=true





Comments