VMWare‎ > ‎

VMWare ESX/ESXi 4.1 Upgrade to 4.1 Update 1 "Incompatible" Update

posted 20 Jun 2011, 11:37 by Tristan Self   [ updated 20 Jun 2011, 12:06 ]
I've been upgrading our ESX hosts to the latest version. From ESX 4.1 to ESX 4.1 U1 (Update 1), its been a little more complicated than i'd like, but here are the strange things i've found. Note this is performing the upgrade using VUM (VMWare Update Manager).

Downloading The Update

Finding the correct package to download is the first problem. As we are upgrading from ESX 4.1 to ESX 4.1 U1 (Update 1) we need to get the package called: update-from-esxi4.1-4.1_update01.zip from the VMWare website.
Easiest way to find it is to search for the above on the vmware site and you should find it no problems, details of the upgrade paths can be found here: http://www.vmware.com/support/vsphere4/doc/vsp_esx41_u1_rel_notes.html

Next the Problem with the Package and Updating the Hosts

Once we have the package (zip) downloaded the easiest way to add the package to VUM is to , open VUM, go to “Configuration” -> “Patch Download Settings”, then click on the “Import Patches” link to import a local zip file. Select the zip file we just downloaded and click on “Next >.”




Once the package is created, you create the baseline and then attach it to the hosts, and I got the frustrating and worrying "incompatable" error message, see below:


Investigating the error from the release notes I found this: http://www.vmware.com/support/vsphere4/doc/vsp_esx41_u1_rel_notes.html#installation


So basically it says to ignore the error or apply a patch. I don't like ignoring errors, so I created a new baseline and applied the patch to the host first to test.

Click on the “Title, Product, Type”, and tick “Vendor ID”, then type in the box: ESX410-201101203 select and click the down arrow on the patch we want to install.

Once the patch has been applied, I reattached the upgrade (4.1 to 4.1 U1) baseline and scanned, now I am seeing "Non-compliant" which is what I should expect, then its just a case of upgrading (remeadiate) all the hosts and rebooting them all.

Phew a bit harder than the upgrade from ESX 3.5 to 4.1 I must say!

http://communities.vmware.com/thread/303119


Comments